FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Steering rack phase 1

 
Post new topic   Reply to topic    Rochdale Owner's Club Forum Index -> General Technical
View previous topic :: View next topic  
Author Message
Jim Reid
Registered User


Joined: 22 Feb 2010
Posts: 11
Location: Hamilton

PostPosted: Tue May 20, 2014 9:25 am    Post subject: Steering rack phase 1 Reply with quote

Hi I am having problems steering on my phase1 I had taken it off during the
Restoration when I refitted the rack i loss end off the rubber boots
To centre the rack an easy fix then fitted the ball joints the n/s was ok but the o/s was pointing in at the front of the wheel no bother just adjust
( aye right) I don't have enough tread on the rack or ball joint
Anybody help
Regards jim
Phase1
OAS 939
Back to top
View user's profile Send private message Send e-mail
John Plant
Registered User


Joined: 07 Nov 2010
Posts: 114
Location: Herefordshire

PostPosted: Tue May 20, 2014 6:48 pm    Post subject: Reply with quote

Jim

I had the same problem with mine I fitted new ball joints, in the end I had to shorten the thread on the ball joints but make sure you have enough thread left to thread in so it is safe

regards

John
Back to top
View user's profile Send private message Send e-mail
Howard Evans
Registered User


Joined: 10 Apr 2009
Posts: 101
Location: Crewe

PostPosted: Tue May 20, 2014 7:15 pm    Post subject: Steering Rack Phase 2 Reply with quote

Interesting! I had the same problem when I fitted new joints to my phase 2 (Triumph) rack. Winding them fully in only enabled me to achieve parallel tracking rather than the toe-in I was aiming to set. Doesn't seem any the worse for it!

Suspect the manufacturer has removed material at the ball end and then had to reduce the length of the bore to maintain strength.
_________________
Olympic PhII CTO 289B
Back to top
View user's profile Send private message Send e-mail
Jim Reid
Registered User


Joined: 22 Feb 2010
Posts: 11
Location: Hamilton

PostPosted: Wed May 28, 2014 3:57 pm    Post subject: Reply with quote

John Plant wrote:
Jim

I had the same problem with mine I fitted new ball joints, in the end I had to shorten the thread on the ball joints but make sure you have enough thread left to thread in so it is safe

regards

John
hi thanks for your reply after many hours looking at it trying this and that I discovered that one of the locknuts was wider than the other
So I managed to get a nut the same width it has made a differance
Regards jim
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Rochdale Owner's Club Forum Index -> General Technical All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group